HTAlt

HTAlt

  • Nuget Nuget
  • Wiki API
  • Website Source

A library which is used in Haltroy apps like Yorot and Backupster.

Latest Stable Version: b1.7.3

Requirements

HTAlt.Standart

HTAlt.Standart only requires .NET Standard 2.0 or newer supported project. HTAlt.Standart can be installed on these frameworks:

  • .NET 5.0 or newer
  • .NET Framework 4.6.1 or newer
  • .NET Core 2.0 or newer
  • Mono 5.4 or newer
  • Xamarin.iOS 10.14 or newer
  • Xamarin.Mac 3.8 or newer
  • Xamarin.Android 8.0 or newer
  • Universal Windows Platform 10.0.16299 or newer
  • Unity 2018,1 or newer

HTAlt.WinForms

HTAlt.WinForms can be installed on Windows Forms projects only. HTAlt.WinForms can be installed on these frameworks:

  • .NET 5.0 or newer
  • .NET Framework 4.6.1 or newer
  • .NET Core 3.1 or newer

HTUPDATE Manager

HTU-Man can be installed by package managers or can be used in a folder without installing it.

  • .NET Core 3.1 supported machine (see this document)
    • NOTE: The Official Document for .NET Core 3.1 might not include every operating system (such as Arch Linux), in order to learn if you operating system supports it or not, search on the internet (for example, I learned that Arch Linux supports .NET Core 3.1 by just typing dotnet arch into Google.)
  • .NET Core 3.1 or newer installed on machine (required only for framework-dependent packages)

Features

  • Tab (Control)
  • Slider (Control)
  • Button (Control)
  • ListView (Control)
  • Switch (Control)
  • MessageBox (Dialog)
  • InputBox (Form)
  • ProgressBar (Control)
  • Tools (Class)
  • Math functions (Tools class & code extensions)
  • Xml Prettifier (Tools class & code extensions)
  • Code Extensions
  • Package updating with HTUPDATE
  • Simple URL shortcuts with HTSHortcut
  • Simple package manager (HTUPDATE Manager)

Usage

HTAlt Packages

You can install them with NuGet (or Nuget Package Manager in Visual Studio) to your project. The commands to install those packages can be found easily on their own NuGet listings.

You can use the packages in their supported projects in both C# and VB.NET by simply adding using HTAlt;/Imports HTAlt (C#/VB.NET) on top of the source files (.cs for C# projects, .vb for VB.NET projects).

To create a .HTUPDATE file, you can see examples here.

To Install or use HTU-Man, you can view this documentation.

Release Branches

Branch .NET Standard .NET Framework/Core Status Release Time
master Standart 2.0 Framework 4.6.1 & Core 3.1 Development (•_•)
b1.8 - Daisy .NET Standard 2.0 .NET Framework 4.6.1 & .NET Core 3.1 Development 2022
b1.7.3 - Night Hotfix .NET Standard 2.0 .NET Framework 4.6.1 & .NET Core 3.1 Latest Release 7 October 2021
b1.7.2 - Night .NET Standard 2.0 .NET Framework 4.6.1 & .NET Core 3.1 Unsupported 7 October 2021
b1.7.1 - Coffee II .NET Standard 2.0 .NET Framework 4.6.1 & .NET Core 3.1 Unsupported 2 September 2021
b1.7.0 Standart 2.0 Framework 4.6.1 & Core 3.1 Unsupported 31 May 2021
b1.6.4 Standart 2.0 Framework 4.6.1 Unsupproted 14 February 2021
b1.6.3 Standart 2.0 Framework 4.6.1 Unsupported 16 December 2020
b1.6.2 Standart 2.0 Framework 4.6.1 Unsupported 22 November 2020
b1.6.1 Standart 2.0 Framework 4.6.1 Unsupported 21 November 2020
b1.6.0 Standart 2.0 Framework 4.6.1 Unsupported 24 September 2020
b1.5.1 Standart 2.0 Framework 4.6.1 Unsupported 29 August 2020
b1.5 Standart 2.0 Framework 4.6.1 Unsupported 31 July 2020
b1.4.2 Standart 2.0 Framework 4.6.1 Unsupported 25 May 2020
b1.4.1 Standart 2.0 Framework 4.6.1 Unsupported 24 May 2020
b1.4 Standart 2.0 Framework 4.6.1 Unsupported 22 May 2020
b1.3h2 None Framework 4.5 Unsupported 13 May 2020
b1.3h1 None Framework 4.5 Unsupported 13 May 2020
b1.3 None Framework 4.5 Unsupported 13 May 2020
b1.2 None Framework 4.5 Unsupported 8 May 2020
b1.1 None Framework 4.5 Unsupported 3 May 2020
b1.0 None Framework 4.5 Unsupported 29 April 2020
a1.9 None Framework 4.5 Unsupported 10 March 2020
a1.8 None Framework 4.5 Unsupported 10 March 2020
a1.7 None Framework 4.5 Unsupported 24 February 2020
a1.6 None Framework 4.5 Unsupported 9 January 2020
a1.5 None Framework 4.5 Unsupported 4 November 2019
a1.4 None Framework 4.5 Unsupported 2 November 2019
a1.3 None Framework 3.5 Unsupported 28 September 2019
a1.2 None None Unavailable Was Embedded to Korot & Playtroy
a1.1 None None Unavailable Was Embedded to Korot & Playtroy
a1.0 None None Unavailable Was Embedded to Korot & Playtroy